Подршка » Проблеми » Problem sa permalinkovima

  • Imam problem sa permalinkovima…
    Za podrazumevano podešavanje je sve ok ali kada promenim sa podrazumevanog na bilo koje drugo (dan i naslov npr.) dobijam Not Found kada pokušam da otvorim stranicu.
    Vidim na stranim forumima da ljudi imaju isti problem, ali nisam uspeo da nađem rešenje. Kod nekih problem prouzrokuju plagini, ali ja još nisam ubacio ni jedan.
    Inače, sajt je na localhost-u…

Посматрање 6 одговора - 1 до 6 (од укупно 6)
  • Уредник Avram

    (@avram)

    Ajmo redom. Da li:

    1. imaš instaliran Apache web server ili neki drugi?
    2. imaš instaliran i uključen mod_rewrite modul za Apache?
    3. je dozvoljeno da fajl .htaccess menja konfiguraciju servera (direktiva AllowOverride treba da bude postavljena na „All“)?
    4. imaš odgovarajući .htaccess fajl (WP bi trebalo da ga kreira)?
    Thread Starter manmar

    (@manmar)

    Imam Apache…
    LoadModule rewrite_module modules/mod_rewrite.so – Uključeno
    .htacces izgleda ovako:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    Gde mi se nalazi AllowOverride?

    Thread Starter manmar

    (@manmar)

    AllowOverride je bila na none, postavio sam je na All, ali i dalje ništa…

    Thread Starter manmar

    (@manmar)

    Sređeno!
    Nisam restartovao Appache nakon što sam menjao httpd.conf…Nakon restarta radi.
    Hvala na pomoći i brzom odgovoru…

    Rešenje ako neko bude imao ovaj problem…
    Otići na Apache > httpd.conf

    Odkomentarisati (skinuti #)
    LoadModule rewrite_module modules/mod_rewrite.so

    Postaviti

    <Directory />
        Options FollowSymLinks
        AllowOverride All
    </Directory>

    Nadam se da ovo ima veze sa gore pomenutim problemom.
    Naime,ja ne koristim „localhost“ sadrzaj je na „pravom“ serveru i imam problem sa linkovima.
    Dakle ,nakon sto sam kreirao novu stranicu i odedio joj kategorije i sve ostalo u Firefoxu radi link ,dok u drugim pretazivacima tipa IE,Opera… izbacuje „Error 404 – Not Found“.
    Probao sam da promenim permalink sa „podrazumevanog“ na „Mesec i Naslov“i kad sam to uradio onda se ne rikazuje uopste …
    Zna li neko o cemu se ovde radi ,totalno sam zbunjen?

    Нема то везе са прегледачом веба. Можда нешто није у реду са .htaccess датотеком или да постоје неки сукоби у правилима за прављење сталних веза.

Посматрање 6 одговора - 1 до 6 (од укупно 6)
  • Тема „Problem sa permalinkovima„ је закључана за нове одговоре.